Announcement

Collapse
No announcement yet.

speedo on shovel

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • speedo on shovel

    finally getting my shovel back to its former glory and i think my speedo has died... i replaced the cable a while ago and just replaced the drive and took for a ride and the needle on the speedo just spins around in circles! LOL any ideas peoples? It the speedo knackered? Also i had some dramas finding a right hand side speedo drive but eventually found one! apparently there mostly left hand mounted??? any other info to add to this peoples?
    cheers

  • #2
    I tryed to find some DIY couldnt so far there is this place.

    http://www.scottspeedometer.com/
    THE NEGATIVE ONE no better don't click
    https://www.youtube.com/watch?x-yt-c...-ts=1422579428
    How's my Spelin, CALL 1-800-BOSS to report my bad spelizin

    Comment


    • #3
      friggen long time since I seen or used a mechanical speedo. crap got on the magnets, wornout bearings /bushings causing a rub, magnet may a got loose.
      THE NEGATIVE ONE no better don't click
      https://www.youtube.com/watch?x-yt-c...-ts=1422579428
      How's my Spelin, CALL 1-800-BOSS to report my bad spelizin

      Comment


      • #4
        YUP,What Vlade said.
        If there is a speedo repair shop in Your area it would be best to have them do the repairs,I have heard of people uncrimping them with a screw driver and cleaning them and using a very light grease such as Lubriplate assembly grease{white stuff in a squeeze tube} and then reassembling them and recrimping with pliers.
        It`s a possibility that after going through all this that the bushings could be shot and may have to either take it to a shop for replacement of bushings or a replacement of the whole unit.
        Personally,I think I would try to pry it apart and clean/lube it but thats just Me and My adventuresome spirit.
        Good hearing from ya Shaggz.
        Ear Tag no. 00030

        Comment


        • #5
          yea and I have chucked one across a shop once after I tried to make it work about a hunerd different ways ,,woreout the put toghetherin parts I dint need to know How fast I was anyway.
          THE NEGATIVE ONE no better don't click
          https://www.youtube.com/watch?x-yt-c...-ts=1422579428
          How's my Spelin, CALL 1-800-BOSS to report my bad spelizin

          Comment


          • #6
            Originally posted by vlade View Post
            yea and I have chucked one across a shop once after I tried to make it work about a hunerd different ways ,,woreout the put toghetherin parts I dint need to know How fast I was anyway.
            heeheeheeee
            Ear Tag no. 00030

            Comment


            • #7
              jus one thought hit me fore I sleeped.. If the cable got too long for some reason... New cable, diffrent parts, routing ? This might force parts inside the speedo to bind up and turn different. Might try backin off the cable retaining nut (or lock) and pullin it out a little runnin it and see if it helps.
              THE NEGATIVE ONE no better don't click
              https://www.youtube.com/watch?x-yt-c...-ts=1422579428
              How's my Spelin, CALL 1-800-BOSS to report my bad spelizin

              Comment


              • #8
                Ya man,that would definetely doo it all righty.
                Ear Tag no. 00030

                Comment

                Working...
                X